Skip to main content

Impact of the CVE-2023-41835 vulnerability on our products

I. Vulnerability summary
CVE-2023-41835 – There is a potential security vulnerability in Apache Struts, a framework for creating enterprise-ready Java web applications (affected versions: Apache Struts 2.0.0 through 2.5.31 and 6.1.2.1 through 6.3.0): 

When a multipart request is performed but some of the fields exceed the maxStringLength limit, the upload files will remain in struts.multipart.saveDir even if the request has been denied. Users are recommended to upgrade to versions Struts 2.5.32 or 6.1.2.2 or Struts 6.3.0.1 or greater, which fix this issue.
II. Impact on our products
Utax products are not affected by this vulnerability.